前提
- アクション編集画面のプレビュー機能では、iframe内に任意のサイトを表示させ、さらにKARTEの接客アクションを表示することができます。
その際にクラウド上で動作するProxyサーバーを介することで、任意のコンテンツを挿入することを可能としています。 - Proxyサーバのタイムアウトは10秒です。
- 埋め込み先と埋め込み元のページは別ドメインとなっております。
そのため、お客様サイトのJavaScriptなどが完全に同じ動作をしないことがございます。(例:親フレームへのアクセスなど)
共通する回避策
弊社側で用意したサンプルページでのプレビューを確認することもできます。
プレビュー上部のURL右の設定をOFFにしていただくとご利用いただけますので、
ご確認の際、あわせてご利用ください。「サイトで確認」機能をご利用ください。
ページ読み込みが失敗する場合
A. サイト側の問題(サーバーサイド)
下記に関して不明な場合は、サイト管理者様にお問い合わせください。
A-1. サイト側でブロッキング処理が行われている
- 原因
- 特定のIPレンジなどに対しサイト側がブロッキングを行っている場合、ページが表示されないことがあります。
- 回避策
- 残念ながら、ProxyサーバーはIPを固定することが難しいため、ブロッキング処理の一部緩和を行ってください。
A-2. サイト側でCORSの制約に引っかかっている
- 原因
- サイト側のCORS policyによっては、CORSエラーが発生しプレビューが正常に表示されないケースがあります
- 回避策
- Access-Control-Allow-Originヘッダーで、KARTE側がプレビュー表示に利用しているドメイン(
*.karte-io-works.in
)を許可してください *.karte-io-works.in
の*
部分は動的に変更されるため、ワイルドカードを利用した指定が必要です
- Access-Control-Allow-Originヘッダーで、KARTE側がプレビュー表示に利用しているドメイン(
A-3. セッション管理を別URLで行うシステム(JSESSIONIDシステム)を採用している
- 原因
- 「httpsで行われたアクセスに対してhttpの特定URLでセッションIDを発行し、httpsにリダイレクトし直すような仕組み」を利用してセッション管理を行っている場合発生します。
- KARTEのProxyサーバーではhttpに対してのアクセスとhttpsに対してのアクセスを同一視していないため、Cookieが共有されません。そのため、リダイレクトループが発生することがあります。
- 回避策
- 上述した「共通する回避策」をご利用ください
A-4. ページ自体のリソースがかなり大きい
- 原因
- Proxyサーバーのタイムアウトは10秒です。そのため、単純にリソースの大きさから読み込み時間がかかってしまっている場合、ページが表示されません
- 回避策
- サイト内の、リソースの大きくないページで表示を試してください。
B. 管理画面のアクセス元環境の問題(クライアントサイド)
下記に関して不明な場合は、お客様環境のシステム管理者様にお問い合わせください。
B-1. リファラが削除されている
- 原因
- セキュリティ上の理由により、ProxyサーバーはKARTE管理画面以外からのアクセスを遮断しています。
- その判定は、HTTPリクエストのリファラーの参照を通して行っています。
- ブラウザーやファイアウォールなどの設定によりリクエストのリファラが削除されいる場合、アクセスできません。
- 回避策
- ブラウザーやファイアウォールの設定を一部緩和する。
B-2. ネットワーク速度が遅く、タイムアウトしてしまう
- 原因
- ネットワーク速度の問題で読み込み時間がかかってしまっている場合、タイムアウトが発生しページが表示されないことがあります
- 回避策
- ネットワーク環境の良いところでお試しください
プレビュー内の表示がおかしくなる場合
ページの一部が文字化けしてしまう
- 原因
- ページ内で読み込んでいるJavaScriptファイルの文字コードがUTF-8以外(Shift_JISなど)の場合、当該JavaScriptファイルでページ内に挿入しているマルチバイト文字(日本語など)が文字化けすることがあります
- 回避策
- 上述した「共通する回避策」をご利用いただくか、ページ内で読み込んでいるJavaScriptファイルの文字コードをUTF-8に変更する改修をご検討ください